Monday, September 26, 2016 | The online resource for training fire investigators

Support

DO NOT call the IAAI office, you need to fill out a support ticket, a response will be sent to your email within 48 hours.

Requirements

The training modules available on CFITrainer.Net® have the following minimum requirements:
Microsoft Internet Explorer 9.0 or later, Firefox 30 or later, Chrome 28 or later, or Safari 7 or later (Failed)
Adobe Flash Player 9.0 or later
Adobe Acrobat Reader 6.0 or later
Screen Resolution of 1024 x 768 or greater
FireHeroLearningNetwork Email Alerts
E-Mail Address:

I would like to hear about the following topics on the CFITrainer.net Podcasts.

CFITrainer Poll
I would like to hear about the following topics on the CFITrainer.net Podcasts.